You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-misc/apertium/files/apertium-3.2.0-autotools.patch

82 lines
3.7 KiB

--- a/apertium/Makefile.am
+++ b/apertium/Makefile.am
@@ -78,7 +78,7 @@
apertium_pretransfer_SOURCES = apertium_pretransfer.cc
apertium_multiple_translations_SOURCES = apertium-multiple-translations.cc
-apertium_multiple_translations_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_multiple_translations_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_destxt_SOURCES = apertium_destxt.cc
apertium_retxt_SOURCES = apertium_retxt.cc
apertium_deshtml_SOURCES = apertium_deshtml.cc
@@ -99,45 +99,45 @@
apertium_remediawiki_SOURCES = apertium_remediawiki.cc
apertium_tagger_SOURCES = apertium_tagger.cc
-apertium_tagger_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_tagger_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_tmxbuild_SOURCES = apertium_tmxbuild.cc
-apertium_tmxbuild_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_tmxbuild_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_preprocess_transfer_SOURCES = transferpp.cc
apertium_preprocess_transfer_LDADD = $(APERTIUM_LIBS) \
- -lapertium$(GENERIC_MAJOR_VERSION)
+ libapertium3.la
apertium_filter_ambiguity_SOURCES = apertium_filter_ambiguity.cc
apertium_filter_ambiguity_LDADD = $(APERTIUM_LIBS) \
- -lapertium$(GENERIC_MAJOR_VERSION)
+ libapertium3.la
apertium_transfer_SOURCES = apertium_transfer.cc
-apertium_transfer_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_transfer_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_interchunk_SOURCES = apertium_interchunk.cc
-apertium_interchunk_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_interchunk_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_postchunk_SOURCES = apertium_postchunk.cc
-apertium_postchunk_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_postchunk_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_lextor_SOURCES = apertium_lextor.cc
-apertium_lextor_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_lextor_LDADD = $(APERTIUM_LIBS) libapertium3.la
#apertium_lextor_eval_SOURCES = apertium-lextor-eval.C
-#apertium_lextor_eval_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+#apertium_lextor_eval_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_tagger_apply_new_rules_SOURCES = apertium_tagger_apply_new_rules.cc
-apertium_tagger_apply_new_rules_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_tagger_apply_new_rules_LDADD = $(APERTIUM_LIBS) libapertium3.la
###apertium_lextor_search_SOURCES = apertium-lextor-search.C
-###apertium_lextor_search_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+###apertium_lextor_search_LDADD = $(APERTIUM_LIBS) libapertium3.la
###pruebas_lextor_SOURCES = pruebas-lextor.C
-###pruebas_lextor_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+###pruebas_lextor_LDADD = $(APERTIUM_LIBS) libapertium3.la
apertium_gen_wlist_lextor_translation_SOURCES = apertium_gen_wlist_lextor_translation.cc
-apertium_gen_wlist_lextor_translation_LDADD = $(APERTIUM_LIBS) -lapertium$(GENERIC_MAJOR_VERSION)
+apertium_gen_wlist_lextor_translation_LDADD = $(APERTIUM_LIBS) libapertium3.la
INCLUDES = -I$(top_srcdir) $(APERTIUM_CFLAGS)
CLEANFILES = *~ apertium_destxt.cc apertium_retxt.cc apertium_deshtml.cc \
--- a/configure.ac
+++ b/configure.ac
@@ -142,7 +142,7 @@
PKG_CHECK_MODULES(APERTIUM, [dnl
- lttoolbox-3.2 >= required_lttoolbox_version dnl
+ lttoolbox >= required_lttoolbox_version dnl
libxml-2.0 >= required_libxml_version dnl
libpcre >= required_libpcre_version], CPPFLAGS="$CPPFLAGS $APERTIUM_CFLAGS"; LIBS="$LIBS $APERTIUM_LIBS")