You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-client/luakit/files/luakit-2.2.1-pkg-config.patch

22 lines
779 B

--- a/config.mk
+++ b/config.mk
@@ -98,15 +98,15 @@
PKGS += javascriptcoregtk-4.0
# Check user has correct packages installed (and found by pkg-config).
-PKGS_OK := $(shell pkg-config --print-errors --exists $(PKGS) && echo 1)
+PKGS_OK := $(shell $(PKG_CONFIG) --print-errors --exists $(PKGS) && echo 1)
ifneq ($(PKGS_OK),1)
$(error Cannot find required package(s\) to build luakit. Please \
check you have the above packages installed and try again)
endif
# Add pkg-config options to compile flags.
-CFLAGS += $(shell pkg-config --cflags $(PKGS))
+CFLAGS += $(shell $(PKG_CONFIG) --cflags $(PKGS))
CFLAGS += -I./
# Add pkg-config options to linker flags.
-LDFLAGS += $(shell pkg-config --libs $(PKGS))
+LDFLAGS += $(shell $(PKG_CONFIG) --libs $(PKGS))