gentoo-overlay/sci-chemistry/avogadro/files/avogadro-1.1.0-textrel.patch

15 lines
756 B
Diff

libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt b/libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt
index fb88316..2ddcfdf 100644
--- a/libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt
+++ b/libavogadro/src/extensions/crystallography/spglib/CMakeLists.txt
@@ -20,6 +20,6 @@ add_library(spglib STATIC ${spglib_SRCS})
set_target_properties(spglib PROPERTIES COMPILE_FLAGS "-w")
# Set -fPIC on x86_64
-if("${CMAKE_SYSTEM_PROCESSOR}" STREQUAL "x86_64")
+if("${CMAKE_SYSTEM_PROCESSOR}" MATCHES "^(i.86|x86|x86_64)$")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fPIC" )
endif()