You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/udunits/files/udunits-2.1.15-autotools.patch

62 lines
1.8 KiB

diff --git a/Makefile.am b/Makefile.am
index 728e587..3c84c1b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,11 +6,11 @@
#
## Process this file with automake to produce Makefile.in
if COND_EXPAT
- SUBDIRS = expat lib prog
+ SUBDIRS = lib prog
else
SUBDIRS = lib prog
endif
-DIST_SUBDIRS = expat lib prog test
+DIST_SUBDIRS = lib prog test
info_TEXINFOS = udunits2.texi
udunits2_TEXINFOS = success.texi failure.texi make.texi
EXTRA_DIST = \
diff --git a/configure.ac b/configure.ac
index 097f6eb..091e673 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,7 +13,7 @@ AC_INIT(UDUNITS, 2.1.15, support-udunits@unidata.ucar.edu)
AC_CONFIG_SRCDIR([lib/converter.c])
AC_CONFIG_AUX_DIR([.])
AM_INIT_AUTOMAKE([foreign subdir-objects])
-AC_CONFIG_HEADERS([config.h expat/expat_config.h])
+AC_CONFIG_HEADERS([config.h])
CFLAGS_COVERAGE=''
LIBS_COVERAGE=''
@@ -37,7 +37,7 @@ AC_ARG_ENABLE([debug],
CFLAGS="-g${CFLAGS:+ $CFLAGS}"
debug=true ;;
no)
- CFLAGS="-O${CFLAGS:+ $CFLAGS}"
+ CFLAGS="${CFLAGS:+ $CFLAGS}"
debug=false ;;
*) AC_MSG_ERROR([bad value ${enableval} for --enable-debug]) ;;
esac],
@@ -110,20 +110,12 @@ AM_CONDITIONAL([HAVE_CUNIT], [test "$LD_CUNIT"])
AC_C_CONST
AC_TYPE_SIZE_T
-# Needed for the Expat subpackage:
-AC_C_BIGENDIAN([byteorder=4321], [byteorder=1234])
-AC_DEFINE_UNQUOTED([BYTEORDER], [$byteorder],
- [Define to 4321 for big-endian and 1234 for little-endian])
-AC_DEFINE([XML_CONTEXT_BYTES], 1024,
- [How much context to retain around the current parse point.])
-
# Checks for library functions.
AC_CHECK_FUNCS([floor memmove memset modf pow strcasecmp strdup strpbrk])
AC_PROG_LIBTOOL
AC_CONFIG_FILES([Makefile
- expat/Makefile
lib/Makefile
lib/xmlFailures/Makefile
lib/xmlSuccesses/Makefile