You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-office/tpp/files/tpp-1.3.1-Makefile.patch

28 lines
854 B

--- tpp-1.3.1.orig/Makefile 2005-06-12 04:39:10.000000000 -0700
+++ tpp-1.3.1/Makefile 2005-07-12 03:46:05.000000000 -0700
@@ -3,10 +3,10 @@
#################################################
BIN = tpp
-prefix=/usr/local
-INSPATH= $(prefix)/bin/
-DOCPATH = $(prefix)/share/doc/tpp
-MANPATH = $(prefix)/share/man/man1
+prefix=/usr
+INSPATH= $(DESTDIR)$(prefix)/bin/
+DOCPATH = $(DESTDIR)$(prefix)/share/doc/tpp-1.3.1
+MANPATH = $(DESTDIR)$(prefix)/share/man/man1
all:
@echo "TPP doesn't need to be built. Run \`make install' in order to install it."
@@ -14,7 +14,9 @@
install :
mkdir -p $(DOCPATH)
install -m644 DESIGN CHANGES COPYING README THANKS $(DOCPATH)
+ mkdir -p $(MANPATH)
install -m644 doc/tpp.1 $(MANPATH)
+ mkdir -p $(INSPATH)
install tpp.rb $(INSPATH)$(BIN)
mkdir -p $(DOCPATH)/contrib
mkdir -p $(DOCPATH)/examples