You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/libpdb++/files/040728-dynlib.patch

13 lines
383 B

diff --git a/libpdb++/Makefile b/libpdb++/Makefile
index bbf0778..286a638 100644
--- a/libpdb++/Makefile
+++ b/libpdb++/Makefile
@@ -32,6 +32,7 @@ install: $(LIBARCH)
$(LIBARCH): $(OBJS)
@echo "Loading $(LIBARCH) ... "
+ $(CXX) $(LDFLAGS) -shared -Wl,--soname,libpdb++.so.0 -o libpdb++.so.0.1 $(OBJS)
@ar cru $(LIBARCH) $(OBJS)
@$(RANLIB) $(LIBARCH)
@echo "done"