You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/coin/files/coin-4.0.0-0001-updated-to-...

26 lines
626 B

From 962e613609ba93301999f83e283b7f489dfac503 Mon Sep 17 00:00:00 2001
From: Giampiero Gabbiani <giampiero@gabbiani.org>
Date: Fri, 10 Jan 2020 14:47:38 +0100
Subject: [PATCH] updated to cmake 3.14
---
CMakeLists.txt | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f32f6ffe3..3ce3a0d3a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,3 +1,8 @@
+if (POLICY CMP0054)
+ # CMake version 3.14.5 warns when the policy is not set and uses OLD behaviour
+ cmake_policy(SET CMP0054 NEW)
+endif()
+
cmake_minimum_required(VERSION 3.0)
set(COIN_MAJOR_VERSION 4)
--
2.26.2