You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/coin/files/coin-4.0.0-0002-cpack.d-is-...

33 lines
1.4 KiB

From be8e3d57aeb5b4df6abb52c5fa88666d48e7d7a0 Mon Sep 17 00:00:00 2001
From: Giampiero Gabbiani <giampiero@gabbiani.org>
Date: Tue, 14 Jan 2020 22:03:51 +0100
Subject: [PATCH] cpack.d is now optional
---
CMakeLists.txt | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ce3a0d3a..755bd9d59 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -95,6 +95,7 @@ option(SPIDERMONKEY_RUNTIME_LINKING "Enable SpiderMonkey runtime linking when ON
option(COIN_VERBOSE "Add verbose debugging information during the configure process." OFF)
option(HAVE_MULTIPLE_VERSION "Forces versioned paths for includes and documentation when ON, usual behaviour otherwise." OFF)
+option(COIN_USE_CPACK "If enabled the cpack subrepo is mandatory" OFF)
cmake_dependent_option(COIN_BUILD_MAC_FRAMEWORK "Build framework instead of dylib on Mac OS X when ON. Only valid if COIN_BUILD_SHARED_LIBS is ON." OFF "APPLE;NOT IOS;COIN_BUILD_SHARED_LIBS" OFF)
cmake_dependent_option(COIN_BUILD_MAC_X11 "Build for X11 on Mac OS X when ON. Default is OFF." OFF "APPLE" OFF)
@@ -820,4 +821,6 @@ endif()
# ############################################################################
# New CPACK section, please see the README file inside cpack.d directory.
-add_subdirectory(cpack.d)
+if (COIN_USE_CPACK)
+ add_subdirectory(cpack.d)
+endif()
--
2.26.2