You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/openr2/files/openr2-1.3.0-fix-build-syst...

31 lines
855 B

--- a/configure.in
+++ b/configure.in
@@ -25,11 +25,6 @@
AC_CONFIG_HEADERS(config.h)
AM_INIT_AUTOMAKE
-# let's default to compile with debugging information
-# most users will not even care about it
-CFLAGS='-ggdb3 -O0'
-CXXFLAGS='-ggdb3 -O0'
-
AC_PROG_CC
AC_PROG_LIBTOOL
AC_LANG([C])
diff -ur ORIG/src/Makefile.am MOD/src/Makefile.am
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,10 +1,10 @@
-AM_CFLAGS = -std=c99 -pedantic -Wall -Werror -Wwrite-strings -Wunused-variable -Wstrict-prototypes -Wmissing-prototypes
+AM_CFLAGS = -std=c99 -pedantic -Werror -Wwrite-strings -Wunused-variable -Wstrict-prototypes -Wmissing-prototypes
if WANT_OR2_TRACE_STACKS
AM_CFLAGS += -DOR2_TRACE_STACKS
endif
if HAVE_SVNVERSION
-AM_CFLAGS += -DREVISION=\"$(shell svnversion -n .)\"
+AM_CFLAGS += -DREVISION=\"0\"
endif
lib_LTLIBRARIES = libopenr2.la