You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/glfw/files/glfw-2.7.7-dyn.patch

32 lines
1021 B

--- lib/x11/Makefile.x11.in
+++ lib/x11/Makefile.x11.in
@@ -8,7 +8,7 @@
##########################################################################
# Default: Build GLFW static library
##########################################################################
-all: libglfw.a libglfw.so
+all: libglfw.a libglfw.so.2.7.7
##########################################################################
@@ -112,7 +112,7 @@
##########################################################################
# Rule for building shared library
##########################################################################
-libglfw.so: $(SHARED_OBJS)
+libglfw.so.2.7.7: $(SHARED_OBJS)
$(CC) $(SOFLAGS) -o $@ $(SHARED_OBJS) $(LFLAGS) $(LIBS)
--- compile.sh
+++ compile.sh
@@ -88,7 +88,7 @@
case "x`uname 2> /dev/null`" in
xLinux)
GLFW_LIB_CFLAGS="$GLFW_LIB_CFLAGS -D_GLFW_USE_LINUX_JOYSTICKS"
- SOFLAGS="-shared -Wl,-soname,libglfw.so"
+ SOFLAGS="-shared -Wl,-soname,libglfw.so.2.7.7"
echo "Linux" 1>&6
;;
xDarwin)