You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/wcd/files/wcd-6.0.2-gentoo.patch

68 lines
1.4 KiB

--- wcd-6.0.2/src/Makefile
+++ wcd-6.0.2/src/Makefile
@@ -45,12 +45,12 @@
CC ?= gcc
STATIC =
-STRIP = strip
+STRIP =
ENABLE_NLS = 1
PACKAGE = wcd
-EXT = .exe
+EXT =
PROGRAM = $(PACKAGE)$(EXT)
BIN = $(PROGRAM)
@@ -328,9 +328,9 @@
# possible values: ncurses, curses, pdcurses, pdcursesw or <empty>
ifdef UCS
- CURSES = ncursesw
+ CURSES = $(shell pkg-config --libs ncursesw)
else
- CURSES = ncurses
+ CURSES = $(shell pkg-config --libs ncurses)
endif
@@ -360,7 +360,7 @@
ifneq (,$(CURSES))
DEFS_CURSES = -DWCD_USECURSES
- LIB_CURSES = -l$(CURSES)
+ LIB_CURSES = $(CURSES)
ifeq (os/2,$(OS))
LIB_CURSES += -ltinfo
endif
@@ -458,15 +458,15 @@
LDFLAGS_USER =
LDFLAGS ?=
-LDFLAGS += $(RPM_LD_FLAGS) \
+LIBS = $(RPM_LD_FLAGS) \
$(LDFLAGS_EXTRA) \
$(NLFLAG) \
$(LDFLAG_STATIC) \
$(LDFLAGS_USER)
-LIBS = $(LIB_CURSES) \
- $(LIB_UNISTRING) \
- $(LIBS_EXTRA)
+LIBS += $(LIB_CURSES) \
+ $(LIB_UNISTRING) \
+ $(LIBS_EXTRA)
DEFS_USER =
DEFS = $(DEF_UNIX) $(DEFS_CURSES) $(EXTRA_DEFS) $(DEFS_USER)
@@ -523,7 +523,7 @@
$(BIN): $(OBJS1)
$(MAKE) status
- $(CC) $(OBJS1) $(LDFLAGS) $(LIBS) -o $@
+ $(CC) $(LDFLAGS) $(OBJS1) -o $@ $(LIBS)
%.o: %.c
$(CC) $(CFLAGS) $(EXTRA_CFLAGS) $(DEFS) -c $< -o $@