You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/sysrqd/files/sysrqd-14-fix-build-system....

22 lines
615 B

--- a/Makefile
+++ b/Makefile
@@ -5,15 +5,15 @@
-Wundef -Wshadow -Wcast-align -Wwrite-strings -Wsign-compare \
-Wunused -Winit-self -Wpointer-arith -Wredundant-decls \
-Wmissing-prototypes -Wmissing-format-attribute -Wmissing-noreturn \
- -std=gnu99 -pipe -DSYSRQD_VERSION="\"$(VERSION)\"" -O3
+ -std=gnu99
+CPPFLAGS += -DSYSRQD_VERSION="\"$(VERSION)\""
SBINDIR=$(DESTDIR)/usr/sbin
#MANDIR=$(DESTDIR)/usr/share/man/man1
INSTALL = install
#MAN=sysrqd.1
-$(BIN): $(O)
- $(CC) $(LDFLAGS) -o $(BIN) $(O)
+all: $(BIN)
install: $(BIN)
$(INSTALL) -d -m 755 $(SBINDIR)