You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-base/pykde4/files/pykde4-4.10.1-arm-sip.patch

23 lines
630 B

See Gentoo bug #322351.
--- CMakeLists.txt
+++ CMakeLists.txt
@@ -101,6 +101,8 @@
${KDEPIMLIBS_INCLUDE_DIRS}
)
+# Pull in ARM configuration options if needed
+STRING(REGEX MATCH "PyQt_qreal_double" SIP_ARM_HACK ${PYQT4_SIP_FLAGS} "")
set(SIP_INCLUDES ${PYQT4_SIP_DIR} sip)
set(SIP_CONCAT_PARTS 8)
if (WIN32)
@@ -108,7 +110,7 @@
else ()
set(SIP_TAGS ALL WS_X11 ${PYQT4_VERSION_TAG})
endif ()
-set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug)
+set(SIP_DISABLE_FEATURES VendorID PyQt_NoPrintRangeBug ${SIP_ARM_HACK})
# Use an extra option when compiling on Python 3.
if (PYTHON_VERSION_MAJOR GREATER 2)