32 lines
957 B
Diff
32 lines
957 B
Diff
From e43745593e4627de8027587cb3b4a465c93fa0b1 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
|
|
Date: Wed, 19 Dec 2012 19:22:29 +0100
|
|
Subject: [PATCH] Do not install zoneinfo files.
|
|
|
|
---
|
|
setup.py | 7 -------
|
|
1 file changed, 7 deletions(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index c8152d5..8f13279 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -13,15 +13,8 @@ me = 'Stuart Bishop'
|
|
memail = 'stuart@stuartbishop.net'
|
|
packages = ['pytz']
|
|
resources = ['zone.tab', 'locales/pytz.pot']
|
|
-for dirpath, dirnames, filenames in os.walk(os.path.join('pytz', 'zoneinfo')):
|
|
- # remove the 'pytz' part of the path
|
|
- basepath = dirpath.split(os.path.sep, 1)[1]
|
|
- resources.extend([os.path.join(basepath, filename)
|
|
- for filename in filenames])
|
|
package_data = {'pytz': resources}
|
|
|
|
-assert len(resources) > 10, 'zoneinfo files not found!'
|
|
-
|
|
setup (
|
|
name='pytz',
|
|
version=pytz.VERSION,
|
|
--
|
|
1.8.0.2
|
|
|