You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/amarok/files/amarok-2.8.90-mysqld-rpath....

13 lines
573 B

--- a/src/core-impl/storage/sql/mysqlestorage/CMakeLists.txt.old 2016-05-04 11:01:25.000000000 -0400
+++ b/src/core-impl/storage/sql/mysqlestorage/CMakeLists.txt 2016-05-04 11:05:24.216625165 -0400
@@ -28,6 +28,9 @@
${ZLIB_LIBRARIES}
)
+SET_TARGET_PROPERTIES(amarok_storage-mysqlestorage PROPERTIES BUILD_WITH_INSTALL_RPATH TRUE)
+SET_TARGET_PROPERTIES(amarok_storage-mysqlestorage PROPERTIES INSTALL_RPATH "${MYSQLD_DIR}")
+
if(NOT WIN32 AND NOT APPLE)
target_link_libraries( amarok_storage-mysqlserverstorage crypt pthread )
endif(NOT WIN32 AND NOT APPLE)