You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/solid-runtime/files/solid-runtime-4.14.3-networ...

20 lines
927 B

Fixes build with networkmanager-1.0.6.
Triggered by http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?h=nm-1-0&id=6f616d4c4b04d5478f60d0311317bc84c5459ea4.
https://bugs.gentoo.org/show_bug.cgi?id=559892
diff --git a/solid-networkstatus/kded/CMakeLists.txt b/solid-networkstatus/kded/CMakeLists.txt
index 633c7f1..341a1ed 100644
--- a/solid-networkstatus/kded/CMakeLists.txt
+++ b/solid-networkstatus/kded/CMakeLists.txt
@@ -20,7 +20,7 @@ if(NETWORKMANAGER_FOUND)
if(NM_0_7)
MESSAGE(STATUS "Adding in-process NetworkManager service-wart to kded module")
set(kded_networkstatus_PART_SRCS ${kded_networkstatus_PART_SRCS} networkmanagerstatus.cpp)
- include_directories(${NETWORKMANAGER_INCLUDE_DIRS})
+ include_directories(${NETWORKMANAGER_INCLUDE_DIRS} ${NM-UTIL_INCLUDE_DIRS})
add_definitions(-DNM_BACKEND_ENABLED)
endif(NM_0_7)
endif(NETWORKMANAGER_FOUND)