You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/synergy/files/synergy-1.9.1-pthread.patch

12 lines
391 B

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,6 +141,8 @@
check_library_exists ("pthread" pthread_create "" HAVE_PTHREAD)
if (HAVE_PTHREAD)
list (APPEND libs pthread)
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -pthread")
+ set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
else()
message (FATAL_ERROR "Missing library: pthread")
endif()