You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libdbusmenu-qt/files/libdbusmenu-qt-0.9.2-option...

18 lines
307 B

--- CMakeLists.txt
+++ CMakeLists.txt
@@ -59,8 +59,13 @@
DESTINATION lib${LIB_SUFFIX}/pkgconfig
)
+
+option(BUILD_TESTS "Build tests" ON)
+
add_subdirectory(src)
-add_subdirectory(tests)
+if(BUILD_TESTS)
+ add_subdirectory(tests)
+endif(BUILD_TESTS)
add_subdirectory(tools)
if(WITH_DOC)