You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/aegisub/files/aegisub-3.2.2-add-missing-p...

41 lines
1.5 KiB

diff --git a/Makefile.inc.in b/Makefile.inc.in
index c93b9dc..8c5678a 100644
--- a/Makefile.inc.in
+++ b/Makefile.inc.in
@@ -99,7 +99,7 @@ LIBS_LIBPULSE = @LIBPULSE_LIBS@
LIBS_LUA = $(TOP)vendor/luajit/src/libluajit.a
LIBS_OPENAL = @OPENAL_LIBS@
LIBS_PORTAUDIO = @PORTAUDIO_LIBS@
-LIBS_PTHREAD = @PTHREAD_LIBS@
+LIBS_PTHREAD = @PTHREAD_LIBS@ -lpthread
ifeq (yes, $(BUILD_DARWIN))
LIBS_LUA = $(TOP)vendor/luajit/src/libluajit-aegisub.so
diff --git a/libaegisub/Makefile b/libaegisub/Makefile
index 64204ef..178044d 100644
--- a/libaegisub/Makefile
+++ b/libaegisub/Makefile
@@ -41,7 +41,8 @@ aegisub_OBJ += $(d)common/dispatch.o
endif
aegisub_PCH := $(d)lagi_pre.h
-aegisub_CPPFLAGS := -I$(d)include -I$(TOP) -fPIC $(CPPFLAGS_BOOST) $(CFLAGS_LUA)
+aegisub_CPPFLAGS := -I$(d)include -I$(TOP) -fPIC \
+ $(CFLAGS_PTHREAD) $(CPPFLAGS_BOOST) $(CFLAGS_LUA)
$(d)common/charset_conv.o_FLAGS := $(CFLAGS_ICONV)
$(d)common/parser.o_FLAGS := -ftemplate-depth=256
diff --git a/tools/Makefile b/tools/Makefile
index 81bcef3..d9f64b8 100644
--- a/tools/Makefile
+++ b/tools/Makefile
@@ -7,7 +7,7 @@ PROGRAM += $(d)osx-bundle-restart-helper
endif
repack-thes-dict_OBJ := $(d)repack-thes-dict.o $(TOP)lib/libaegisub.a
-repack-thes-dict_LIBS := $(LIBS_BOOST) $(LIBS_ICU)
+repack-thes-dict_LIBS := $(LIBS_BOOST) $(LIBS_ICU) $(LIBS_PTHREAD)
repack-thes-dict_CPPFLAGS := -I$(TOP) -I$(TOP)libaegisub/include $(CFLAGS_ICU)
PROGRAM += $(d)repack-thes-dict