You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/vulkan-loader/files/vulkan-loader-Fix-layers-in...

27 lines
1021 B

From 4ae095d8d3e668311b3db3657af753dfb39a149c Mon Sep 17 00:00:00 2001
From: Nick Sarnie <sarnex@gentoo.org>
Date: Sun, 22 Apr 2018 18:44:48 -0400
Subject: [PATCH] Make the layers install into the data root directory
Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
---
layers/CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/layers/CMakeLists.txt b/layers/CMakeLists.txt
index 9ade6a03..c1a3cedd 100644
--- a/layers/CMakeLists.txt
+++ b/layers/CMakeLists.txt
@@ -142,7 +142,7 @@ if(UNIX)
VERBATIM
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/linux/${config_file}.json
)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/staging-json/${config_file}.json DESTINATION ${CMAKE_INSTALL_SYSCONFDIR}/vulkan/explicit_layer.d)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/staging-json/${config_file}.json DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/vulkan/explicit_layer.d)
endforeach(config_file)
endif()
endif()
--
2.17.0