You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/rsync/files/rsync-3.2.0_pre3-simd_check...

25 lines
907 B

https://github.com/WayneD/rsync/issues/19
--- rsync-3.2.0pre3/configure.ac 2020-06-17 19:12:09.000000000 +0200
+++ rsync-3.2.0pre3/configure.ac 2020-06-17 19:12:09.000000000 +0200
@@ -202,7 +202,7 @@
if test x"$enable_simd" = x"yes"; then
# For x86-64 SIMD, g++ is also required
if test x"$build_cpu" = x"x86_64"; then
- if test x"$CXX" = x"g++"; then
+ if echo "$CXX" | grep -q 'g++$'; then
# AC_MSG_RESULT() called below
SIMD="$SIMD x86_64"
else
--- rsync-3.2.0pre3/configure.sh 2020-06-17 19:12:09.000000000 +0200
+++ rsync-3.2.0pre3/configure.sh 2020-06-17 19:12:09.000000000 +0200
@@ -4842,7 +4842,7 @@
if test x"$enable_simd" = x"yes"; then
# For x86-64 SIMD, g++ is also required
if test x"$build_cpu" = x"x86_64"; then
- if test x"$CXX" = x"g++"; then
+ if echo "$CXX" | grep -q 'g++$'; then
# AC_MSG_RESULT() called below
SIMD="$SIMD x86_64"
else