You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/gmp/files/gmp-5.0.0-s390.diff

69 lines
1.8 KiB

stolen from SuSE
--- configure.in
+++ configure.in
@@ -1050,6 +1050,9 @@
;;
+ s390x-*-*)
+ path="s390x" ;;
+
# IBM s/370 and similar
[s3[6-9]0*-*-*])
gcc_cflags="-O2 $fomit_frame_pointer"
--- configure
+++ configure
@@ -1050,6 +1050,9 @@
;;
+ s390x-*-*)
+ path="s390x" ;;
+
# IBM s/370 and similar
s3[6-9]0*-*-*)
gcc_cflags="-O2 $fomit_frame_pointer"
--- mpn/s390/gmp-mparam.h
+++ mpn/s390/gmp-mparam.h
@@ -20,7 +20,8 @@
MA 02110-1301, USA. */
-/* GMP_LIMB_BITS etc generated by configure */
+#define GMP_LIMB_BITS 32
+#define BYTES_PER_MP_LIMB 4
/* Generated by tuneup.c, 2001-12-03, gcc 2.95 */
--- mpn/s390x/gmp-mparam.h
+++ mpn/s390x/gmp-mparam.h
@@ -0,0 +1,27 @@
+/* gmp-mparam.h -- Compiler/machine parameter header file.
+
+Copyright (C) 1991, 1993, 1994, 1995 Free Software Foundation, Inc.
+
+This file is part of the GNU MP Library.
+
+The GNU MP Library is free software; you can redistribute it and/or modify
+it under the terms of the GNU Library General Public License as published by
+the Free Software Foundation; either version 2 of the License, or (at your
+option) any later version.
+
+The GNU MP Library is distributed in the hope that it will be useful, but
+WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+or FITNESS FOR A PARTICULAR PURPOSE. See the GNU Library General Public
+License for more details.
+
+You should have received a copy of the GNU Library General Public License
+along with the GNU MP Library; see the file COPYING.LIB. If not, write to
+the Free Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
+MA 02111-1307, USA. */
+
+#define GMP_LIMB_BITS 64
+#define BYTES_PER_MP_LIMB 8
+#define BITS_PER_LONGINT 64
+#define BITS_PER_INT 32
+#define BITS_PER_SHORTINT 16
+#define BITS_PER_CHAR 8