You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-benchmarks/httperf/files/httperf-0.8-optional-ssl.diff

21 lines
694 B

diff --exclude='*~' --exclude='.*' -I '$Id:' -urN httperf-0.8.orig/configure.in httperf-0.8/configure.in
--- httperf-0.8.orig/configure.in 2005-08-17 15:51:17.000000000 -0400
+++ httperf-0.8/configure.in 2005-08-17 16:06:20.000000000 -0400
@@ -39,8 +39,14 @@
dnl Checks for libraries.
dnl Replace `main' with a function in -lm:
AC_CHECK_LIB(m, main)
-AC_CHECK_LIB(crypto, main)
-AC_CHECK_LIB(ssl, SSL_version)
+
+AC_MSG_CHECKING([whether to enable SSL support])
+AC_ARG_ENABLE(ssl, [ --enable-ssl Enable SSL support])
+AC_MSG_RESULT([$enable_ssl])
+if test "$enable_ssl" = yes; then
+ AC_CHECK_LIB(crypto, main)
+ AC_CHECK_LIB(ssl, SSL_version)
+fi
dnl Checks for header files.