You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-benchmarks/piozone/files/piozone-1.0-gentoo.diff

50 lines
1.5 KiB

diff -Naur piozone-1.0.orig/Makefile piozone-1.0/Makefile
--- piozone-1.0.orig/Makefile 2003-07-10 18:54:51.000000000 -0300
+++ piozone-1.0/Makefile 2003-07-10 19:02:41.000000000 -0300
@@ -19,3 +19,6 @@
dist: version distclean
(PACKNAME=`basename \`pwd\`` ; cd .. ; $(TAR) cf - $$PACKNAME | $(GZIP) -9 >$$PACKNAME.tar.gz)
+
+install:
+ install -D piozone /usr/bin/piozone
diff -Naur piozone-1.0.orig/piozone.c piozone-1.0/piozone.c
--- piozone-1.0.orig/piozone.c 2003-07-10 18:54:51.000000000 -0300
+++ piozone-1.0/piozone.c 2003-07-10 14:48:44.000000000 -0300
@@ -20,7 +20,7 @@
#include <fcntl.h>
#include <time.h>
#include <signal.h>
-
+#define uint64_t u_int64_t
#define KiB ((uint64_t) 1024)
#define MiB ((uint64_t) 1024*KiB)
#define GiB ((uint64_t) 1024*MiB)
@@ -73,7 +73,7 @@
int count = 0;
int nr = 0;
- llseek(fd, off, SEEK_SET);
+ lseek64(fd, off, SEEK_SET);
signal(SIGALRM, sigalrm_handler);
stopf = 0;
printf("Testing... ");
@@ -121,7 +121,7 @@
printf("Testing... ");
alarm(ts);
while (!stopf &&
- llseek(fd, off+((rand()&area)*MiB), SEEK_SET) != -1 &&
+ lseek64(fd, off+((rand()&area)*MiB), SEEK_SET) != -1 &&
(nr = read(fd, iobuf, len)) == len)
{
print_dial();
@@ -159,7 +159,7 @@
off = 0;
del = 64*GiB;
- while (del > 8*KiB && llseek(fd, off+del, SEEK_SET) != -1)
+ while (del > 8*KiB && lseek64(fd, off+del, SEEK_SET) != -1)
{
if (read(fd, buf, 8*KiB) < 0)
del >>= 1;