You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/spacerider/files/spacerider-0.13-gentoo.patch

28 lines
737 B

--- a/Makefile
+++ b/Makefile
@@ -3,12 +3,12 @@
BINDIR=/usr/bin/
MANDIR=/usr/share/man/man1/
DATADIR=/usr/share/games/spacerider/
-CXX=g++
+CXX?=g++
CP=cp
MKDIR=mkdir -p
INSTALL=install
RM=rm -f
-CXXFLAGS=-Wall -fomit-frame-pointer -O3 `sdl-config --cflags`
+CXXFLAGS+=$(shell sdl-config --cflags)
OBJS=main.o globals.o spacerider.o music.o sprite.o enemy.o effect.o visible.o box.o features.o font.o image.o bullet.o
OUTPUT=spacerider
LIBS=`sdl-config --libs` -lSDL_image -lSDL_ttf -lSDL_mixer -lSDL_net -lSDL_gfx
@@ -22,8 +22,7 @@
$(OUTPUT): $(OBJS)
- $(CXX) $(CXXFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
- strip $(OUTPUT)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(OUTPUT) $(OBJS) $(LIBS)
%.o: %.cpp
$(CXX) $(CXXFLAGS) -c $<