You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/redis/files/redis-2.4.4-tcmalloc.patch

21 lines
442 B

https://github.com/antirez/redis/pull/218
diff --git a/src/Makefile b/src/Makefile
index 72edcad..3e43990 100644
--- a/src/Makefile
+++ b/src/Makefile
@@ -35,12 +35,14 @@ else
endif
ifeq ($(USE_TCMALLOC),yes)
+ USE_JEMALLOC=no
ALLOC_DEP=
ALLOC_LINK=-ltcmalloc
ALLOC_FLAGS=-DUSE_TCMALLOC
endif
ifeq ($(USE_TCMALLOC_MINIMAL),yes)
+ USE_JEMALLOC=no
ALLOC_DEP=
ALLOC_LINK=-ltcmalloc_minimal
ALLOC_FLAGS=-DUSE_TCMALLOC