You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libffi/files/libffi-3.3-compiler-vendor-...

34 lines
896 B

https://bugs.gentoo.org/753299
--- a/testsuite/lib/libffi.exp
+++ b/testsuite/lib/libffi.exp
@@ -287,9 +287,6 @@ proc libffi-init { args } {
verbose "libffi $blddirffi"
# Which compiler are we building with?
- set tmp [grep "$blddirffi/config.log" "^ax_cv_c_compiler_vendor.*$"]
- regexp -- {^[^=]*=(.*)$} $tmp nil compiler_vendor
-
if { [string match $compiler_vendor "gnu"] } {
set gccdir [lookfor_file $tool_root_dir gcc/libgcc.a]
if {$gccdir != ""} {
--- a/configure.ac
+++ b/configure.ac
@@ -59,6 +59,7 @@ fi
cat > local.exp <<EOF
set CC_FOR_TARGET "$CC"
set CXX_FOR_TARGET "$CXX"
+set compiler_vendor "$ax_cv_c_compiler_vendor"
EOF
AM_MAINTAINER_MODE
--- a/configure
+++ b/configure
@@ -17402,6 +17402,7 @@ fi
cat > local.exp <<EOF
set CC_FOR_TARGET "$CC"
set CXX_FOR_TARGET "$CXX"
+set compiler_vendor "$ax_cv_c_compiler_vendor"
EOF