You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-office/scribus/files/scribus-1.5.8-findhyphen-1....

55 lines
1.2 KiB

diff --git a/scribus/CMakeLists.txt b/scribus/CMakeLists.txt
index aec69d3..9451404 100644
--- a/scribus/CMakeLists.txt
+++ b/scribus/CMakeLists.txt
@@ -587,7 +587,9 @@ set(SCRIBUS_SOURCES
${SCRIBUS_GMAGICK_SRC}
)
-if(NOT HAVE_HYPHEN)
+if(HAVE_HYPHEN)
+ include_directories(${HYPHEN_INCLUDE_DIR})
+else()
include_directories(third_party/hyphen)
set(SCRIBUS_SOURCES
${SCRIBUS_SOURCES}
@@ -678,12 +680,6 @@ if(HAVE_PODOFO)
endif()
-if(HAVE_HYPHEN)
- target_link_libraries(${EXE_NAME} PRIVATE
- ${HYPHEN_LIBRARY}
- )
-endif()
-
if(GESTURE_FRAME_PREVIEW)
message(STATUS "Enable gesture frame preview [experimental]")
@@ -743,6 +739,12 @@ if(WANT_PCH)
target_precompile_headers(${EXE_NAME} PRIVATE scribus_pch.h)
endif()
+if(HAVE_HYPHEN)
+ target_link_libraries(${EXE_NAME} PRIVATE
+ ${HYPHEN_LIBRARY}
+ )
+endif()
+
if(WIN32)
set_target_properties(${EXE_NAME}
PROPERTIES
diff --git a/scribus/hyphenator.h b/scribus/hyphenator.h
index 7fa4abd..2863c70 100644
--- a/scribus/hyphenator.h
+++ b/scribus/hyphenator.h
@@ -13,7 +13,7 @@ for which a new license (GPL+exception) is in place.
#include <QSet>
#include "scribusapi.h"
-#include "third_party/hyphen/hyphen.h"
+#include <hyphen.h>
class ScribusDoc;
class ScribusMainWindow;