You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-sound/aumix/files/aumix-2.9.1-tinfo.patch

23 lines
737 B

https://bugs.gentoo.org/578722
--- aumix-2.9.1/configure.ac
+++ aumix-2.9.1/configure.ac
@@ -69,6 +69,8 @@
[ --without-ncurses compile with no ncurses or mouse support],
AC_MSG_RESULT([Compiling without ncurses support]),[
dnl Checks for ncurses library.
+ AC_CHECK_LIB(tinfo, main, TINFO_LIB="-ltinfo", TINFO_LIB=)
+ AC_SUBST(TINFO_LIB)
AC_CHECK_LIB(ncurses, initscr, initscr=on, initscr=off)
if test $initscr = on; then
CURSLIB="ncurses"
@@ -83,7 +85,7 @@
fi
fi
if test x$CURSLIB != x; then
- LIBS="-l$CURSLIB $LIBS"
+ LIBS="-l$CURSLIB $TINFO_LIB $LIBS"
AC_DEFINE(HAVE_CURSES, 1,
[Define this if you have (n)curses and want to use it.])
AC_CHECK_LIB($CURSLIB, getmouse,