You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-arch/tarsync/files/tarsync-0.2.1-make.patch

14 lines
295 B

Respect CC, CPPFLAGS and LDFLAGS.
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@
CC=gcc
endif
tarsync: main.o names.o tar.o string-misc.o fs.o options.o excludes.o
- gcc $(CFLAGS) $^ -o tarsync -lcfile
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $^ -o tarsync -lcfile
all: tarsync
clean: