You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/screen/files/screen-4.0.3-cppflags.patch

12 lines
406 B

--- screen-4.0.3/Makefile.in
+++ screen-4.0.3/Makefile.in
@@ -68,7 +68,7 @@
$(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
.c.o:
- $(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(DEFS) $(OPTIONS) $(CFLAGS) $<
+ $(CC) -c -I. -I$(srcdir) $(M_CFLAGS) $(DEFS) $(OPTIONS) $(CPPFLAGS) $(CFLAGS) $<
install_bin: .version screen
-if [ -f $(DESTDIR)$(bindir)/$(SCREEN) ] && [ ! -f $(DESTDIR)$(bindir)/$(SCREEN).old ]; \