You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/pg_top/files/pg_top-3.6.2.patch

30 lines
724 B

--- configure.ac.orig 2013-09-20 10:11:20.256444684 +0400
+++ configure.ac 2013-09-20 10:16:30.262459612 +0400
@@ -90,7 +90,7 @@
DBCFLAGS="-I$INCLUDEDIR"
LIBDIR=`$PG_CONFIG --libdir`
-DBLDFLAGS="-L$LIBDIR -lpq"
+DBLDFLAGS="-L$LIBDIR"
AC_SUBST(DBCFLAGS)
AC_SUBST(DBLDFLAGS)
@@ -109,6 +109,8 @@
AC_SEARCH_LIBS(inet_aton, resolv, AC_DEFINE(HAVE_INET_ATON, 1,
[inet_aton is already defined]))
+AC_SEARCH_LIBS(PQexec, pq)
+
# check for libraries required by extension
extlibs=""
if test -n "$with_ext" -a -f "${srcdir}/ext/$with_ext.libs"; then
@@ -216,8 +218,6 @@
AC_SUBST(SRC)
AC_SUBST(OBJ)
-CFLAGS="-Wall -g"
-
AC_MSG_CHECKING(for installation settings)
# calculate appropriate settings
OWNER=""