You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-fps/quakeforge/files/quakeforge-0.5.5-keys.patch

104 lines
2.7 KiB

--- nq/source/sys_sdl.c.old 2007-01-14 12:34:48.000000000 +0100
+++ nq/source/sys_sdl.c 2007-01-14 12:35:43.000000000 +0100
@@ -63,6 +63,7 @@
#include "QF/console.h"
#include "QF/qargs.h"
#include "QF/sys.h"
+#include "QF/progs.h"
#include "client.h"
#include "compat.h"
@@ -107,6 +108,9 @@
#endif
}
+extern void Key_Progs_Init (progs_t *pr);
+void (*x)() = Key_Progs_Init;
+
#ifndef SDL_main
# define SDL_main main
#endif
--- qw/source/cl_sys_sdl.c.old 2007-01-14 12:29:25.000000000 +0100
+++ qw/source/cl_sys_sdl.c 2007-01-14 12:30:50.000000000 +0100
@@ -63,6 +63,7 @@
#include "QF/console.h"
#include "QF/qargs.h"
#include "QF/sys.h"
+#include "QF/progs.h"
#include "client.h"
#include "compat.h"
@@ -108,6 +109,9 @@
#endif
}
+extern void Key_Progs_Init (progs_t *pr);
+void (*x)() = Key_Progs_Init;
+
#ifndef SDL_main
# define SDL_main main
#endif
--- qw/source/cl_sys_unix.c.old 2007-01-14 12:33:15.000000000 +0100
+++ qw/source/cl_sys_unix.c 2007-01-14 12:34:02.000000000 +0100
@@ -56,6 +56,7 @@
#include "QF/console.h"
#include "QF/qargs.h"
#include "QF/sys.h"
+#include "QF/progs.h"
#include "host.h"
#include "netchan.h"
@@ -73,6 +74,9 @@
int skipframes;
+extern void Key_Progs_Init (progs_t *pr);
+void (*x)() = Key_Progs_Init;
+
int
main (int c, const char *v[])
{
--- nq/source/sys_unix.c.old 2007-01-14 13:01:20.000000000 +0100
+++ nq/source/sys_unix.c 2007-01-14 13:01:38.000000000 +0100
@@ -69,6 +69,9 @@
fcntl (0, F_SETFL, fcntl (0, F_GETFL, 0) & ~O_NONBLOCK);
}
+extern void Key_Progs_Init (progs_t *pr);
+void (*x)() = Key_Progs_Init;
+
int
main (int c, const char *v[])
{
--- configure.old 2007-01-14 14:06:22.000000000 +0100
+++ configure 2007-01-14 14:06:43.000000000 +0100
@@ -22733,7 +22733,7 @@
int
main ()
{
-void *(*foo)(size_t) = alloca;
+void *foo = alloca(sizeof(void));
;
return 0;
}
@@ -32304,7 +32304,7 @@
if test "x$BUILD_SW" = xyes; then
- VID_REND_NOINST_TARGETS="$VID_REND_NOINST_TARGETS libQFrenderer_sw.la"
+ VID_REND_TARGETS="$VID_REND_TARGETS libQFrenderer_sw.la"
VID_MODEL_TARGETS="$VID_MODEL_TARGETS libQFmodels_sw.la"
fi
if test "x$BUILD_SW32" = xyes; then
--- libs/video/renderer/Makefile.in.old 2007-01-14 15:00:14.000000000 +0100
+++ libs/video/renderer/Makefile.in 2007-01-14 15:02:08.000000000 +0100
@@ -409,7 +409,7 @@
libQFrenderer_gl_la_LIBADD = gl/libgl.la
libQFrenderer_gl_la_SOURCES = $(common_sources)
libQFrenderer_gl_la_DEPENDENCIES = gl/libgl.la
-libQFrenderer_sw_la_LDFLAGS = @STATIC@
+libQFrenderer_sw_la_LDFLAGS = -version-info 1:0:0 -rpath $(libdir)
libQFrenderer_sw_la_LIBADD = sw/libsw.la
libQFrenderer_sw_la_SOURCES = $(common_sources)
libQFrenderer_sw_la_DEPENDENCIES = sw/libsw.la