You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-office/scribus/files/scribus-1.4.4-ppc64-fpic.patch

20 lines
1.1 KiB

scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt b/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt
index 18898a7..ba872b9 100755
--- a/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt
+++ b/scribus/plugins/tools/2geomtools/lib2geom/CMakeLists.txt
@@ -18,9 +18,9 @@ SET(2GEOM_VERSION 0.1.0)
# http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3 and
# http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=559133
-IF (ARCH_X86_64 EQUAL 1 OR ARCH_HPPA EQUAL 1 OR ARCH_MIPS EQUAL 1 OR ARCH_MIPS_64 EQUAL 1)
+IF (ARCH_X86_64 EQUAL 1 OR ARCH_HPPA EQUAL 1 OR ARCH_MIPS EQUAL 1 OR ARCH_MIPS_64 EQUAL 1 OR ARCH_PPC_64 EQUAL 1)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC")
-ENDIF (ARCH_X86_64 EQUAL 1 OR ARCH_HPPA EQUAL 1 OR ARCH_MIPS EQUAL 1 OR ARCH_MIPS_64 EQUAL 1)
+ENDIF (ARCH_X86_64 EQUAL 1 OR ARCH_HPPA EQUAL 1 OR ARCH_MIPS EQUAL 1 OR ARCH_MIPS_64 EQUAL 1 OR ARCH_PPC_64 EQUAL 1)
OPTION(2GEOM_BUILD_SHARED
"Build lib2geom and libtoy as shared libraries."