You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/shm/files/shm-1.2.2-compiler.patch

12 lines
464 B

--- setup.py 2010-06-26 03:29:30.000000000 +0200
+++ setup.py 2010-06-26 03:30:10.000000000 +0200
@@ -84,7 +84,7 @@
filename = "%d.c" % i
file(path + filename, "w").write(src % ('_' * i))
- cmd = ["cc", "-c", "-o", "/dev/null", "%s" % path + filename]
+ cmd = [os.environ.get("CC", "cc"), "-c", "-o", "/dev/null", "%s" % path + filename]
po = popen2.Popen4(cmd)
if not po.wait(): underscores[i] = True