You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-libs/libsamplerate/files/libsamplerate-0.1.3-dontbui...

33 lines
1.2 KiB

Index: libsamplerate-0.1.3/examples/Makefile.am
===================================================================
--- libsamplerate-0.1.3.orig/examples/Makefile.am
+++ libsamplerate-0.1.3/examples/Makefile.am
@@ -3,7 +3,7 @@
bin_PROGRAMS = sndfile-resample
-noinst_PROGRAMS = varispeed-play timewarp-file
+EXTRA_PROGRAMS = varispeed-play timewarp-file
SAMPLERATEDIR =../src
INCLUDES = -I$(srcdir)/$(SAMPLERATEDIR) @OS_SPECIFIC_INCLUDES@
Index: libsamplerate-0.1.3/tests/Makefile.am
===================================================================
--- libsamplerate-0.1.3.orig/tests/Makefile.am
+++ libsamplerate-0.1.3/tests/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = misc_test termination_test simple_test callback_test \
+EXTRA_PROGRAMS = misc_test termination_test simple_test callback_test \
reset_test multi_channel_test snr_bw_test \
float_short_test varispeed_test callback_hang_test \
src-evaluate throughput_test
@@ -55,7 +55,7 @@ throughput_test_LDADD = $(SAMPLRATEDIR)
#===============================================================================
-check: $(noinst_PROGRAMS)
+check: $(EXTRA_PROGRAMS)
date
uname -a
./misc_test