You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/nagios-core/files/use-INSTALL-to-install-them...

60 lines
2.1 KiB

From 26bef86bad804836babd9d99accfc247eb744132 Mon Sep 17 00:00:00 2001
From: Michael Orlitzky <michael@orlitzky.com>
Date: Wed, 12 Nov 2014 08:35:28 -0500
Subject: [PATCH 1/1] Use $(INSTALL) to install themes.
Most of the images installed under the htdocs folder are installed
mode 644 with owner:group nagios:nagios. This is due to the use of
$(INSTALL) in html/Makefile. However, the theme images and stylesheets
are currently installed with a simple "cp -r", which leads to
inconsistencies like the following:
$ cd /usr/share/nagios/htdocs/images
$ ls action*.gif
-rw-rw-r-- 1 nagios nagios 1.3K 2014-11-12 08:22 action.gif
-rw-r--r-- 1 root root 1.3K 2014-11-12 08:22 action-graph.gif
-rw-r--r-- 1 root root 171 2014-11-12 08:22 action-nagios.gif
-rw-r--r-- 1 root root 162 2014-11-12 08:22 action-orig.gif
By using $(INSTALL) in the install-exfoliation and install-classicui
targets, we enforce some consistency.
---
Makefile.in | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/Makefile.in b/Makefile.in
index 1341160..67e1502 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -300,8 +300,11 @@ install-webconf:
@echo ""
install-exfoliation:
- cp -rf contrib/exfoliation/stylesheets/* $(DESTDIR)$(HTMLDIR)/stylesheets
- cp -rf contrib/exfoliation/images/* $(DESTDIR)$(HTMLDIR)/images
+ for file in contrib/exfoliation/stylesheets/*.*; \
+ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/stylesheets; done
+
+ for file in contrib/exfoliation/images/*.*; \
+ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images; done
@echo ""
@echo "*** Exfoliation theme installed ***"
@@ -309,8 +312,11 @@ install-exfoliation:
@echo ""
install-classicui:
- cp -rf html/stylesheets/* $(DESTDIR)$(HTMLDIR)/stylesheets
- cp -rf html/images/* $(DESTDIR)$(HTMLDIR)/images
+ for file in html/stylesheets/*.*; \
+ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/stylesheets; done
+
+ for file in html/images/*.*; \
+ do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images; done
@echo ""
@echo "*** Classic theme installed ***"
--
2.0.4