You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-proxy/torsocks/files/fix-find-libc.so.patch

13 lines
634 B

diff -Nuar torsocks-2.0.0-rc3.orig/configure.ac torsocks-2.0.0-rc3/configure.ac
--- torsocks-2.0.0-rc3.orig/configure.ac 2013-11-03 13:24:51.000000000 -0500
+++ torsocks-2.0.0-rc3/configure.ac 2014-01-26 12:49:55.157606016 -0500
@@ -132,7 +132,7 @@
dnl Get libc full system path. Use prefix or some hardcoded standard
dnl location on Unixish system.
AC_MSG_CHECKING(location of libc.so)
-for DIR in "$prefix/lib" "$prefix/usr/lib" '/lib' '/usr/lib'; do
+for DIR in "$prefix/lib*" "$prefix/usr/lib*" '/lib*' '/usr/lib*'; do
if test "${LIBC_PATH}" = ""; then
LIBC_PATH=`$FIND $DIR -name "libc.so.?" 2>/dev/null | $TAIL -1`
fi