You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/fann/files/fann-2.2.0-examples.patch

24 lines
937 B

--- examples/Makefile.orig 2012-01-24 05:31:40.000000000 +0000
+++ examples/Makefile 2012-05-08 19:00:08.000000000 +0100
@@ -1,7 +1,6 @@
# This makefile is on purpose not made with configure, to show how to use the library
# The make file requires that the fann library is installed (see ../README)
-GCC=gcc
TARGETS = xor_train xor_test xor_test_fixed simple_train steepness_train simple_test robot mushroom cascade_train scaling_test scaling_train
DEBUG_TARGETS = xor_train_debug xor_test_debug xor_test_fixed_debug cascade_train_debug
@@ -9,10 +8,10 @@
all: $(TARGETS)
%: %.c Makefile
- $(GCC) -O3 $< -o $@ -lfann -lm
+ $(CC) $(CFLAGS) $< -lfann -lm -o $@
%_fixed: %.c Makefile
- $(GCC) -O3 -DFIXEDFANN $< -o $@ -lfixedfann -lm
+ $(CC) $(CFLAGS) -DFIXEDFANN $< -lfixedfann -lm -o $@
clean:
rm -f $(TARGETS) $(DEBUG_TARGETS) xor_fixed.data *.net *~ *.obj *.exe *.tds noscale.txt withscale.txt scale_test_results.txt