You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-mathematics/maxima/files/wish-1.patch

29 lines
929 B

diff -r -U1 maxima-5.35.1.orig/configure.ac maxima-5.35.1/configure.ac
--- maxima-5.35.1.orig/configure.ac 2014-12-13 06:44:51.000000000 +0600
+++ maxima-5.35.1/configure.ac 2014-12-15 16:30:07.574773386 +0600
@@ -989,6 +989,11 @@
[ --with-wish=<prog> Use <prog> for Tk wish shell (default wish)],
- [WISH="${withval}"],
- [WISH="wish"])
+ [],
+ [with_wish="wish"])
+case "${with_wish}" in
+ no) WISH="none" ;;
+ yes) WISH="wish" ;;
+ *) WISH="${with_wish}" ;;
+esac
AC_SUBST(WISH)
-
+AM_CONDITIONAL(WANT_TK, test x"${with_wish}" != xno)
diff -r -U1 maxima-5.35.1.orig/interfaces/Makefile.am maxima-5.35.1/interfaces/Makefile.am
--- maxima-5.35.1.orig/interfaces/Makefile.am 2013-10-07 10:37:11.000000000 +0700
+++ maxima-5.35.1/interfaces/Makefile.am 2014-12-15 16:31:18.056770422 +0600
@@ -1,2 +1,6 @@
+if WANT_TK
SUBDIRS = emacs xmaxima
+else
+SUBDIRS = emacs
+endif
EXTRA_DIST = bin/xmaxima.iss