You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-misc/zoneminder/files/zoneminder-1.26.5-automagic...

35 lines
1.0 KiB

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 83e9d81..8619c8b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -171,6 +171,7 @@ else(PCRE_LIBRARIES)
set(optlibsnotfound "${optlibsnotfound} PCRE")
endif(PCRE_LIBRARIES)
+if(HAVE_GCRYPT)
# gcrypt (using find_library and find_path)
find_library(GCRYPT_LIBRARIES gcrypt)
if(GCRYPT_LIBRARIES)
@@ -187,7 +188,11 @@ if(GCRYPT_LIBRARIES)
else(GCRYPT_LIBRARIES)
set(optlibsnotfound "${optlibsnotfound} GCrypt")
endif(GCRYPT_LIBRARIES)
+else(HAVE_GCRYPT)
+ set(optlibsnotfound "${optlibsnotfound} GCrypt")
+endif(HAVE_GCRYPT)
+if(HAVE_GNUTLS)
# gnutls (using find_library and find_path)
find_library(GNUTLS_LIBRARIES gnutls)
if(GNUTLS_LIBRARIES)
@@ -205,6 +210,9 @@ if(GNUTLS_LIBRARIES)
else(GNUTLS_LIBRARIES)
set(optlibsnotfound "${optlibsnotfound} GnuTLS")
endif(GNUTLS_LIBRARIES)
+else(HAVE_GNUTLS)
+ set(optlibsnotfound "${optlibsnotfound} GnuTLS")
+endif(HAVE_GNUTLS)
# mysqlclient (using find_library and find_path)
find_library(MYSQLCLIENT_LIBRARIES mysqlclient PATH_SUFFIXES mysql)