You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-misc/axel/files/axel-2.4-buildsystem.patch

24 lines
566 B

Makefile | 4 ++--
1 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index 1c3863a..b43fcff 100644
--- a/Makefile
+++ b/Makefile
@@ -51,13 +51,13 @@ uninstall-etc:
### MAIN PROGRAM
$(OUTFILE): axel.o conf.o conn.o ftp.o http.o search.o tcp.o text.o
- $(CC) *.o -o $(OUTFILE) $(LFLAGS)
+ $(CC) $(LDFLAGS) *.o -o $(OUTFILE) $(LFLAGS)
ifndef DEBUG
-$(STRIP) $(OUTFILE)
endif
.c.o:
- $(CC) -c $*.c -o $*.o -Wall $(CFLAGS)
+ $(CC) $(CPPFLAGS) -c $*.c -o $*.o -Wall $(CFLAGS)
install-bin:
mkdir -p $(DESTDIR)$(BINDIR)/