You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-libs/libspnav/files/libspnav-0.2.2-makefile.patch

28 lines
926 B

diff -Npur libspnav-0.2.2.orig/Makefile.in libspnav-0.2.2/Makefile.in
--- libspnav-0.2.2.orig/Makefile.in 2012-01-31 22:40:36.619349333 +0100
+++ libspnav-0.2.2/Makefile.in 2012-01-31 22:41:52.554347975 +0100
@@ -11,7 +11,7 @@ CFLAGS = $(opt) -I.
LDFLAGS = $(ldopt) -shared -Wl,-soname,$(soname)
.PHONY: all
-all: $(lib_a) $(lib_so)
+all: $(lib_so)
$(lib_a): $(obj)
$(AR) rcs $@ $(obj)
@@ -31,10 +31,10 @@ distclean:
rm -f $(obj) $(lib_a) $(lib_so) Makefile
.PHONY: install
-install: $(lib_a) $(lib_so)
- cp $(lib_a) $(PREFIX)/$(libdir)/$(lib_a)
- cp $(lib_so) $(PREFIX)/$(libdir)/$(lib_so)
- for h in $(hdr); do cp -p $(srcdir)/$$h $(PREFIX)/include/; done
+install: $(lib_so)
+ mkdir -p $(DESTDIR)$(PREFIX)/$(libdir) $(DESTDIR)$(PREFIX)/include
+ cp $(lib_so) $(DESTDIR)$(PREFIX)/$(libdir)/$(lib_so)
+ for h in $(hdr); do cp -p $(srcdir)/$$h $(DESTDIR)$(PREFIX)/include/; done
.PHONY: uninstall
uninstall: