You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-admin/sagan/files/json_header_location.patch

27 lines
966 B

diff --git a/configure.ac b/configure.ac
--- a/configure.ac
+++ b/configure.ac
@@ -194,7 +194,7 @@
if test "$LOGNORM" = "yes"; then
AC_MSG_RESULT([------- liblognorm support is enabled -------])
AC_CHECK_HEADER([liblognorm.h])
- AC_CHECK_HEADERS([json/json.h json.h], [break], [AC_MSG_ERROR([json-c headers not found or not usable.
+ AC_CHECK_HEADERS([json-c/json.h json.h], [break], [AC_MSG_ERROR([json-c headers not found or not usable.
This library is important for the correlation aspects of Sagan! Please see
https://wiki.quadrantsec.com/bin/view/Main/LibLogNorm. To disable this feature
use the --disable-lognorm flag.])])
diff --git a/src/sagan-liblognorm.c b/src/sagan-liblognorm.c
--- a/src/sagan-liblognorm.c
+++ b/src/sagan-liblognorm.c
@@ -40,9 +40,7 @@
#include <lognorm.h>
#if defined(HAVE_JSON_JSON_H)
-# include <json/json.h>
-#else
-# include <json.h>
+# include <json-c/json.h>
#endif
#include "sagan.h"