You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-analyzer/wireshark/files/wireshark-1.11.3-gtk-deprec...

30 lines
1.0 KiB

--- a/configure.ac
+++ b/configure.ac
@@ -1491,26 +1491,6 @@
wireshark_man=""
fi
-if test "$have_gtk" = "yes" ; then
- # If we have GTK then add flags for it.
-
- CPPFLAGS="-DGDK_PIXBUF_DISABLE_DEPRECATED $CPPFLAGS"
- CPPFLAGS="-DGDK_DISABLE_DEPRECATED $CPPFLAGS"
- if test \( $gtk_config_major_version -eq 3 -a $gtk_config_minor_version -ge 10 \) ; then
- ## Allow use of deprecated & disable deprecated warnings if Gtk >= 3.10;
- ## The deprecations in Gtk 3.10 will not be fixed ...
- CPPFLAGS="-DGDK_DISABLE_DEPRECATION_WARNINGS $CPPFLAGS"
- else
- CPPFLAGS="-DGTK_DISABLE_DEPRECATED $CPPFLAGS"
- fi
- CPPFLAGS="-DGTK_DISABLE_SINGLE_INCLUDES $CPPFLAGS"
- if test ! \( $gtk_config_major_version -eq 2 -a $gtk_config_minor_version -lt 20 \) ; then
- # Enable GSEAL when building with GTK > 2.20
- # (Versions prior to 2.22 lacked some necessary accessors.)
- CPPFLAGS="-DGSEAL_ENABLE $CPPFLAGS"
- fi
-fi
-
# XXX - Is this really necessary? When we build with both Gtk+ and Qt it works...
if test "$use_glib_cflags" = "true"; then
# Use GLIB_CFLAGS