40 lines
1,001 B
Diff
40 lines
1,001 B
Diff
--- gcc-3.2.2/configure.in
|
|
+++ gcc-3.2.2/configure.in
|
|
@@ -517,37 +517,6 @@
|
|
esac
|
|
fi
|
|
|
|
-# Handle ${copy_dirs}
|
|
-set fnord ${copy_dirs}
|
|
-shift
|
|
-while [ $# != 0 ]; do
|
|
- if [ -f $2/COPIED ] && [ x"`cat $2/COPIED`" = x"$1" ]; then
|
|
- :
|
|
- else
|
|
- echo Copying $1 to $2
|
|
-
|
|
- # Use the install script to create the directory and all required
|
|
- # parent directories.
|
|
- if [ -d $2 ]; then
|
|
- :
|
|
- else
|
|
- echo >config.temp
|
|
- ${srcdir}/install-sh -c -m 644 config.temp $2/COPIED
|
|
- fi
|
|
-
|
|
- # Copy the directory, assuming we have tar.
|
|
- # FIXME: Should we use B in the second tar? Not all systems support it.
|
|
- (cd $1; tar -cf - .) | (cd $2; tar -xpf -)
|
|
-
|
|
- # It is the responsibility of the user to correctly adjust all
|
|
- # symlinks. If somebody can figure out how to handle them correctly
|
|
- # here, feel free to add the code.
|
|
-
|
|
- echo $1 > $2/COPIED
|
|
- fi
|
|
- shift; shift
|
|
-done
|
|
-
|
|
# Configure extra directories which are host specific
|
|
|
|
case "${host}" in
|