You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-scheme/guile-gnome-platform/files/2.16.1-gcc45.patch

12 lines
343 B

--- common.mk
+++ common.mk
@@ -50,7 +50,7 @@
guile-snarf $(GUILE_SNARF_CFLAGS) $< > $@ \
|| { rm $@; false; }
.c.doc:
- $(CPP) -DSCM_MAGIC_SNARF_DOCS $(GUILE_SNARF_CFLAGS) $< \
+ $(CPP) -P -DSCM_MAGIC_SNARF_DOCS $(GUILE_SNARF_CFLAGS) $< \
| grep -E '^\^\^ {.*\^\^ }' > $@ || { rm $@; false; }
%.scm guile-gnome-gw-%.c: %-spec.scm