You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/appdirs/files/appdirs-1.4.3-distutils.patch

26 lines
782 B

Force setup.py to use distutils in order to break setuptools cyclic dependency.
--- a/setup.py
+++ b/setup.py
@@ -3,10 +3,7 @@
import os
import os.path
# appdirs is a dependency of setuptools, so allow installing without it.
-try:
- from setuptools import setup
-except ImportError:
- from distutils.core import setup
+from distutils.core import setup
import appdirs
tests_require = []
@@ -45,8 +42,6 @@
Programming Language :: Python :: Implementation :: CPython
Topic :: Software Development :: Libraries :: Python Modules
""".split('\n') if c.strip()],
- test_suite='test.test_api',
- tests_require=tests_require,
keywords='application directory log cache user',
author='Trent Mick',
author_email='trentm@gmail.com',