You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dialup/openl2tp/files/openl2tp-1.8-ldflags.patch

74 lines
2.6 KiB

diff -Naur openl2tp-1.8.werror/Makefile openl2tp-1.8/Makefile
--- openl2tp-1.8.werror/Makefile 2010-11-28 17:18:02.000000000 +0300
+++ openl2tp-1.8/Makefile 2010-11-28 17:22:27.950475976 +0300
@@ -266,10 +266,10 @@
etags $(wildcard *.c) $(wildcard *.h)
openl2tpd: $(L2TPD_SRCS.o)
- $(CC) -o $@ $^ $(LDFLAGS.l2tpd)
+ $(CC) $(LDFLAGS) -o $@ $^ $(LDFLAGS.l2tpd)
l2tpconfig: $(L2TPCONFIG_SRCS.o)
- $(CC) -o $@ $^ $(LDFLAGS.l2tpconfig)
+ $(CC) $(LDFLAGS) -o $@ $^ $(LDFLAGS.l2tpconfig)
%.o: %.c
$(CC) -c $(CFLAGS) $< -o $@
diff -Naur openl2tp-1.8.werror/cli/Makefile openl2tp-1.8/cli/Makefile
--- openl2tp-1.8.werror/cli/Makefile 2010-11-28 17:18:27.000000000 +0300
+++ openl2tp-1.8/cli/Makefile 2010-11-28 17:22:27.950475976 +0300
@@ -19,7 +19,7 @@
$(AR) rus $@ $^
cli_test: $(CLI_SRCS_TEST.o) libcli.a
- $(CC) -o $@ $(CLI_SRCS_TEST.o) $(LDFLAGS.cli_test)
+ $(CC) $(LDFLAGS) -o $@ $(CLI_SRCS_TEST.o) $(LDFLAGS.cli_test)
clean:
$(RM) $(CLI_SRCS.o) $(CLI_SRCS_TEST.o) libcli.a cli_test $(wildcard *.d)
diff -Naur openl2tp-1.8.werror/plugins/Makefile openl2tp-1.8/plugins/Makefile
--- openl2tp-1.8.werror/plugins/Makefile 2010-11-22 17:05:29.000000000 +0300
+++ openl2tp-1.8/plugins/Makefile 2010-11-28 17:22:27.950475976 +0300
@@ -1,7 +1,7 @@
CFLAGS := $(CFLAGS.optimize) -MMD -Wall \
-isystem ../include \
-I. -I.. -I../usl -fPIC $(EXTRA_CFLAGS)
-LDFLAGS := -shared
+LDFLAGS.plugins := -shared
PLUGINS.c:= ppp_unix.c ppp_null.c ipsec.c event_sock.c
@@ -21,7 +21,7 @@
$(RM) $(PLUGINS.so) $(wildcard *.o) $(wildcard *.d) $(SRC.generated)
%.so: %.c
- $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $<
+ $(CC) $(LDFLAGS) -o $@ $(LDFLAGS.plugins) $(CFLAGS) $<
install: all
$(INSTALL) -d $(DESTDIR)$(SYS_LIBDIR)/openl2tp
diff -Naur openl2tp-1.8.werror/test/Makefile openl2tp-1.8/test/Makefile
--- openl2tp-1.8.werror/test/Makefile 2007-05-28 18:28:53.000000000 +0400
+++ openl2tp-1.8/test/Makefile 2010-11-28 17:25:52.871882050 +0300
@@ -3,7 +3,7 @@
all: pppd_dummy
pppd_dummy: pppd_dummy.c
- $(CC) -o $@ $<
+ $(CC) $(LDFLAGS) -o $@ $<
clean:
-$(RM) pppd_dummy
diff -Naur openl2tp-1.8.werror/usl/Makefile openl2tp-1.8/usl/Makefile
--- openl2tp-1.8.werror/usl/Makefile 2010-11-28 17:18:15.000000000 +0300
+++ openl2tp-1.8/usl/Makefile 2010-11-28 17:22:27.950475976 +0300
@@ -26,7 +26,7 @@
$(AR) rus $@ $^
usl_test: $(USL_SRCS_TEST.o) libusl.a
- $(CC) -o $@ $(USL_SRCS_TEST.o) $(LDFLAGS.usl_test)
+ $(CC) $(LDFLAGS) -o $@ $(USL_SRCS_TEST.o) $(LDFLAGS.usl_test)
clean:
-$(RM) $(USL_SRCS.o) $(USL_SRCS_TEST.o) libusl.a usl_test $(wildcard *.d)