You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-dialup/openl2tp/files/openl2tp-1.8-werror.patch

37 lines
1.4 KiB

diff -Naur openl2tp-1.8.orig/Makefile openl2tp-1.8/Makefile
--- openl2tp-1.8.orig/Makefile 2010-11-22 12:47:26.000000000 +0300
+++ openl2tp-1.8/Makefile 2010-11-28 17:18:02.547651027 +0300
@@ -154,7 +154,7 @@
CPPFLAGS= $(CPPFLAGS.l2tptest) $(CPPFLAGS-y)
CFLAGS= -I. -Iusl -Icli -isystem include \
- -MMD -Wall -Werror -Wno-strict-aliasing \
+ -MMD -Wall -Wno-strict-aliasing \
$(CPPFLAGS) $(CPPFLAGS.dmalloc) \
-DSYS_LIBDIR=$(SYS_LIBDIR)
LDFLAGS.l2tpd= -Wl,-E -L. -Lusl -lusl -ldl $(LIBS.dmalloc) -lc
diff -Naur openl2tp-1.8.orig/cli/Makefile openl2tp-1.8/cli/Makefile
--- openl2tp-1.8.orig/cli/Makefile 2010-11-12 15:28:47.000000000 +0300
+++ openl2tp-1.8/cli/Makefile 2010-11-28 17:18:27.707453102 +0300
@@ -7,7 +7,7 @@
LDFLAGS.cli_test= -L.. -L. $(READLINE_LDFLAGS) -lcli -lusl -lreadline -lcurses -lc
-CFLAGS= $(CFLAGS.optimize) -MMD -Wall -Werror -I.. $(READLINE_CFLAGS)
+CFLAGS= $(CFLAGS.optimize) -MMD -Wall -I.. $(READLINE_CFLAGS)
.PHONY: all test clean
diff -Naur openl2tp-1.8.orig/usl/Makefile openl2tp-1.8/usl/Makefile
--- openl2tp-1.8.orig/usl/Makefile 2010-11-04 19:27:08.000000000 +0300
+++ openl2tp-1.8/usl/Makefile 2010-11-28 17:18:15.615816682 +0300
@@ -14,7 +14,7 @@
endif
CPPFLAGS+= $(CFLAGS.optimize) -g
-CFLAGS= -I. -MMD -Wall -Werror -Wno-strict-aliasing $(CPPFLAGS) $(CPPFLAGS.dmalloc)
+CFLAGS= -I. -MMD -Wall -Wno-strict-aliasing $(CPPFLAGS) $(CPPFLAGS.dmalloc)
.PHONY: all test clean